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GPS-X Lite Exercises 

Refer to the Quick Start Guide GPS-X Lite available from the Help selection on the menu bar for supporting 

information on how to perform specific actions that will be used in the following exercises.  

For more detailed content related to the fully-functional version of GPS-X, users can reference the 

Technical Reference for GPS-X and Complete User Guide for GPS-X.  

Note:  

• GPS-X Lite implements a limited version of the International Water Association Activated 

Sludge Model no. 1 (ASM1). 

• The simulation results obtained in GPS-X Lite can differ slightly based on several factors 

including the model’s initial conditions, convergence criteria, and rounding. Therefore, 

you may observe minor variances between the model results and provided solutions. If 

you find significant differences (>0.1%) then we recommend that you check your model 

setting and model inputs. 

• Refer Appendix -A for more details of the biological models used in GPS-X Lite. 
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Exercise 1 – Configuration of the Starting Point 

Layout 

Note: Only make the specified changes outlined in the steps below as this layout will be used at the starting 

point for all subsequent exercises. 

1. Open a new model layout in GPS-X Lite. (You will be prompted with “Close current layout”; 

choose Yes.) 

2. Navigate to the process table on the left-hand side of the window.  

3. Within the appropriate process group, left-click and drag the following process objects onto the 

drawing board.  

• Influent – Wastewater Influent 

• Suspended Growth Processes – Plug-Flow Tank  

• Secondary Clarifiers – Circular Secondary Clarifier  

• Tools – Wastewater Outfall  

Note: In GPS-X Lite only specific unit objects are available to the user. All items that are greyed-out 

are disabled and have only been included to demonstrate what is available in the fully functional version 

of GPS-X. In addition, users have access to only one instance of each available object. 

4. Select the Locator button and zoom-in on the model layout so there is less white space showing on 

the drawing board and the icons are enlarged.  
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5. Create the following connection paths: 

a) Wastewater Influent → PFR Influent (upper reactor connection point) 

b) PFR Effluent → Secondary Clarifier Influent 

c) Secondary Clarifier Effluent → Wastewater Outfall  

d) Secondary Clarifier Underflow (the bottom connection point from the reactor) → PFR 

Recycle Influent (lower reactor connection point) 
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Note: The stream connections must be exactly as specified in the image above.  

6. Click on the Labels button located on the toolbar to display the stream and object names. Make the 

following adjustments to the names of the model objects by right-clicking on the object and 

selecting Labels… from the dropdown menu.  

• Wastewater Influent: 

o Label: Influent  

o influent: wwinf 

 

• Plug-Flow Tank: 

o Label: Bioreactor 

o input: wwinf 

o recycle: RAS 

o overflow: mlss 

 

• Circular Secondary Clarifier: 

o Label: Secondary Clarifier 

o influent: mlss 

o overflow: effluent 

o pump: WAS 

o underflow: RAS 

(a) (b) 
(c) 

(d) 
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• Wastewater Outfall: 

o Label: Outfall 

o input: effluent 

 

 

Note:  

• Once you have specified the name of a stream in one location, the name will automatically 

appear at the other end of the connection.  

• After specifying labels, they will not appear in a reloaded layout unless View > Display 

Labels > Stream/Objects has been selected. 

 

7. Right-click on the Bioreactor and go to Input Parameters > Physical and set the number of 

reactors to 1. This change allows the PFR model object to be modelled as a complete mixed (CM) 

reactor.  
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8. Right-click on the Bioreactor and navigate to Input Parameters > Operational and change the 

specify oxygen transfer by… to Entering airflow, and set the total air flow into aeration tank 

to 30,000 m3/d. 

 

9. A useful feature in GPS-X Lite is the ability to quickly review the changes the user has made to the 

default model settings. Right-click on the Bioreactor and navigate to Summary of changes. In the 

form that appears you should see a list of all input changes.  

 

10. Click on the arrow button to the right of the total air flow into aeration tank variable in the form. 

The same form in Step 8 should appear. Close this window. 

11. Save the model layout under an appropriate name (i.e. startingpoint). 
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To become familiar with how to navigate to various parts of the interface, recreate and fill out the 

table below through completion of the following steps. Make note of the units indicated in the table.  

(Exercise 1 – Question 1) 

 

 Model Object Parameter Unit Value 

Modelling Mode Wastewater Influent Influent Flow m3/d  

 Bioreactor Maximum Volume m3  

 Secondary Clarifier Surface m2  

Simulation Mode  Influent Ammonia mgN/L  

 Bioreactor  Temperature C  

 Bioreactor Hydraulic Residence Time hr  

 Secondary Clarifier TSS Removal Efficiency %  

12. Right-click on the Wastewater Influent object and navigate to Flow > Flow Data and report the 

value of the influent flow rate.   

13. Right-click on the Bioreactor and navigate to Input Parameters > Physical and report the value of 

the maximum volume.  

14. Right-click on the Secondary Clarifier and navigate to Input Parameters > Physical and report the 

value of the surface area.  

15.  Switch into simulation mode. The “Model Builder” will activate if this is the first simulation to 

be conducted with the layout and its parameters. Once the model is built, run the simulation by 

pressing the Start button located in the bottom-left corner of the interface, on the simulation toolbar.  
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Note: Values will appear in the locations specified in the images below once the simulation has 

been run. 

Below the Outputs menu ribbon, output tabs have been automatically created for the four model 

objects on the drawing board: Influent, Bioreactor, Secondary Clarifier, and Outfall. 

16. Select the Influent output tab and report the ammonia concentration under the Simulation Results 

header. 

 

17. Select the Bioreactor output tab and report the temperature in the top section of the panel.  

 

18. Right-click on the mlss stream of the Bioreactor (ensure that the mouse changes to a connecting 

arrow before clicking) and navigate to Output Variables > Hydraulic Variables and report the 

hydraulic residence time in the table.  
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19. Right-click on the effluent stream of the Secondary Clarifier (ensure that the mouse changes to a 

connecting arrow before clicking) and navigate to Output Variables > Performance Variables and 

report the TSS removal efficiency in the table.  

 

20. Select the Bioreactor output tab, and in the top-right corner of the panel, choose from the Display 

dropdown, Ammonia N. Notice that the values of the streams on the bioreactor image will become 

updated. Report a screenshot of these results. (Exercise 1 – Question 2) 
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Exercise 2 – Influent Advisor  

This exercise will explore two concepts related to wastewater influent characterization.  

a) Relationship between state and composite variables using the GPS-X influent advisor tool 

b) Effect of influent characterization on plant performance 

 

1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. Switch into Modelling Mode.  

3. Right-click on the Influent Wastewater object and navigate to Composition > Influent 

Characterization to open the Influent Advisor tool.  
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The Influent Advisor is divided into 3 sections: User Inputs, State Variables, and Composite 

Variables. The following segment provides some background into how these variables are related 

in the carbon, nitrogen library (cnlib) in GPS-X.  

User Inputs – these values are editable by the user (Note: access is limited to Influent Fractions 

in GPS-X Lite)  

State Variables – these are the basic variables that are continuously integrated in the model over 

time. In practical applications the state variables are typically not easily measurable or interpretable.  

Composite Variables – these are variables that are calculated (composed of) the state variables. 

Unlike the state variables, the composite variables can be combined into forms that are typically 

measured, such as TSS, BOD, COD, and TKN.  

The box-and-arrow diagrams below demonstrate the relationships that exist between the user inputs 

and state and composite variables. The notation is as follows: 

• Variables in BOLD CAPITALS are the composite variables 

• Connection line shows the direction of the calculation 

• Multiple lines converging indicate summation  

• Stoichiometric parameters above a connection line indicate multiplication of the parameter 

with the previous boxed variable 

• A broken line indicates that the stoichiometric parameters are model dependent 

Note: GPS-X uses the usual assumption that 1 mg ultimate BOD equals 1 mg of degradable COD. 



Exercise 2 – Influent Advisor 

15 

 

The definitions of the state and composite variables used in diagrams are summarized in the table 

below. 

 

a) Relationship between the CNLIB state variables and the TSS, BOD, and COD composite 

variables 

 

State Variables Composite Variables 

si Soluble inert material BOD5 5-day Biological Oxygen Demand 

ss Readily biodegradable soluble substrate SBOD5 Soluble BOD5 

xs Slowly biodegradable substrate XBOD5 Particulate BOD5 

xbh Heterotrophic biomass BODU Ultimate Biological Oxygen Demand 

xba Autotrophic biomass SBODU Soluble BODU 

xsto Internal cell storage products XBODU Particulate BODU 

xu Unbiodegradable cell products COD Chemical Oxygen Demand 

xi Particulate inert material SCOD Soluble COD 

xii Inorganic inert particulate XCOD Particulate COD 

sno Nitrite and nitrate X Total Suspended Solids 

snh Ammonia nitrogen VSS Volatile Suspended Solids  

snd Soluble organic nitrogen XISS Total Inorganic Suspended Solids 

xnd Particulate biodegradable organic 
nitrogen 

TN Total Nitrogen 

  TKN Total Kjeldahl Nitrogen 

  STKN Soluble TKN 

  XTKN Particulate TKN 
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b) Relationship between the CNLIB state variables and the TN and TKN composite variables  

 

 

Visualization of the relationships outlined above can be explored using the GPS-X Influent Advisor 

tool. 

4. Select the total suspended solids (x) variable within the 3rd panel in the window under the 

Composite Variables header.  

Selection of this variable should highlight the volatile suspended solids variable (vss) under the 

Composite Variables panel and the VSS/TSS ratio (ivt) under the User Inputs column.  

This relationship is also presented at the bottom of the window in the form of an equation: 

𝑥 =
𝑣𝑠𝑠

𝑖𝑣𝑡
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5.  Select the volatile suspended solids variable to determine how this composite variable is 

calculated.  
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Substitute the equation for vss into the previous equation for x. 

𝑥 =
𝑣𝑠𝑠

𝑖𝑣𝑡
 

𝑥 =
(
𝑥𝑐𝑜𝑑
𝑖𝑐𝑣

)

𝑖𝑣𝑡
 

Now find the equation for x in terms of cod, scod, icv, and ivt by selecting the appropriate item to 

reveal the corresponding equation and substituting it into the above equation.  In a similar manner 

determine the equation for x in terms of cod, frss, frsi, icv, and ivt. (Note: these variables define x 

solely in terms of user input variables.) (Exercise 2 – Question 1) 

6. Select the total carbonaceous BOD5 (bod) variable within the Composite Variables panel under the 

Composite Variables header.  

 

7. Repeat the same process as in steps 4-5, to determine the equation relating total BOD5 (bod) to total 

COD (cod) using the appropriate Influent Fractions” and Organic Fractions” parameters., (Exercise 

2 – Question 2). Please note that xsto is not a state variable in ASM1 and it is not included in the 

calculations.  

8. Close the Influent Advisor.  

9. Right-click on the Bioreactor and navigate to Input Parameters > Operational and change the total 

air flow into aeration tank to 20,000 m3/d.   
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10. Right-click on the Secondary Clarifier and navigate to Input Parameters > Operational and change 

the pumped flow to 100 m3/d. 

 

11. Switch into Simulation Mode. Rebuild the model when prompted.  

12. From the Simulation Toolbar navigate to Scenario > New and create a new scenario called 

“Influent.” 
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In the following scenarios you will explore the effect of changes in the influent characterization on 

the plant performance.  

 

Scenario 1 – XCOD/VSS Ratio 

 

In a word processor, create the table below to record your answers for the following steps. 

 

 Influent Bioreactor Secondary Clarifier 

XCOD/VSS 

Ratio = 1.8 

TSS (mg/L)  MLSS (mg/L)  RAS TSS (mg/L)  

VSS (mg/L)  MLVSS (mg/L)  Effluent TSS (mg/L)  

XCOD/VSS 

Ratio = 1.4 

TSS (mg/L)  MLSS (mg/L)  RAS TSS (mg/L)  

VSS (mg/L)  MLVSS (mg/L)  Effluent TSS (mg/L)  

 

13. Run the simulation at steady-state. By default, the XCOD/VSS Ratio (icv) is set to 1.8, fbod= 0.66, 

and ivt = 0.75. Check the Influent Advisor (Step 3 above). 

14. Through navigation to the various output tabs, record your observations in the table. In addition, 

report a screenshot of the simulation results on the Outfall output tab. (Exercise 2 – Question 3)  
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15. Right-click on the Influent Wastewater object and navigate to Composition > Influent 

Characterization. In the User Inputs panel, under the Influent Fractions header adjust the 

XCOD/VSS ratio (icv) to 1.4. (Note: In Simulation mode, you can edit the Influent Characterization 

ONLY in new scenarios, not the Default Scenario.) 

 

16. Rerun the simulation. Complete the table and report a screenshot of the results shown in the Outfall 

output tab. (Exercise 2 – Question 4) 

Scenario 2 – BOD5/BODultimate ratio (Exercise 2 – Question 5) 
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17. Right-click on the Influent object and navigate to Composition > Influent Characterization. Set all 

user inputs to the default values (icv = 1.8, fbod = 0.66, ivt = 0.75).  

 

18. With all user inputs at the default values complete the first row of the table below with values from 

the Influent Advisor.   

 

Location 

Total 

Carbonaceous 

BOD5 (bod) 

Filtered 

Carbonaceous 

BOD5 (sbod) 

Particulate 

Carbonaceous BOD5 

(xbod) 

BOD5/BODultimate 

ratio = 0.66 

Influent 

(wwinf) 

   

Bioreactor 

Effluent (mlss) 

   

BOD5/BODultimate 

= 0.4 

Influent 

(wwinf) 

   

Bioreactor 

Effluent (mlss) 
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19. Close the Influent Advisor and run the simulation.  

20. Right-click on the mlss steam and navigate to Output Variables > Composite Variables and 

complete the second row within the table. The value for mlss total carbonaceous BOD5 is provided 

in the first screen. Select the More… button to find another screen with filtered carbonaceous BOD5 

and particulate carbonaceous BOD5 values. 

21. Repeat steps 17-20 after adjusting the BOD5/BODultimate ratio in the Influent Advisor to 0.4. 

Report the values in final two rows of the above table. Discuss the results.  
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Scenario 3 – VSS/TSS Ratio (Exercise 2 – Question 6) 

In your word processor create the table below to record your responses for the following scenario. 

  VSS/TSS Ratio = 0.75 VSS/TSS Ratio = 0.9 

Influent 

TSS (mg/L)   

Total Inorganic Suspended Solids 

(mg/L) 

  

Bioreactor 

MLSS (mg/L)   

Ammonia (mg/L)   

Secondary 

Clarifier 

Solids Loading Rate (kg/(m2.d))   

RAS COD (mg/l)   

Outfall 

TSS (mg/L)   

cBOD5 (mg/L)   

COD (mg/L)   

TN (mg/L)   

 

22. Open the Influent Advisor and reset the BOD5/BODultimate ratio to the default value of 0.66. 

From the Composite Variables column of the Influent Advisor record the influent concentrations 

of total suspended solids (x) and total inorganic suspended solids (xiss) in the first two rows 

within the VSS/TSS Ratio = 0.75 column of the table. 
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23. Close the influent advisor and run the simulation. Complete the table by accessing the appropriate 

output tabs.  

24. Repeat steps 22-23 for a VSS/TSS Ratio of 0.9 to complete the second column of the table. 

 



Exercise 3 – Comparing the Performance of Alternative Bioreactor Configurations 

26 

 

Exercise 3 – Comparing the Performance of 

Alternative Bioreactor Configurations 

The purpose of this exercise is to compare the effluent quality from conventional activated sludge systems 

with different bioreactor configurations: 

a) Complete mixed, no recycle 

b) Complete mixed, biological solids recycle  

c) Plug flow, biological solids recycle 

d) Plug flow with step-feeding, biological solids recycle 

 

1. Open the Starting Point model layout that was developed in Exercise 1.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. Save the layout under a different name. 

3. In modelling mode, right-click on the Secondary Clarifier and navigate to Input Parameters > 

Operational. Change the underflow rate to 0 m3/d; now there is no recycle between the clarifier 

and the aeration basin.  
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4. Switch into simulation mode. Rebuild the model when prompted. 

5. Create a new output graph tab. Right-click on the tab and rename to “Operational Performance.”  

6. Right-click on the Outfall object and navigate to Output Variables > Flow. From the flow dialog 

box that appears, drag the flow variable to the new graph tab. Right-click on the graph to change 

its display to Digital from the Output Graph Type dropdown. Follow the same steps for the 

subsequent output variables from the Outfall object (drag the variables to the existing digital graph): 

• Composite Variables: total suspended solids, total carbonaceous BOD5 

• State Variables: dissolved oxygen, free and ionized ammonia 

 

The screen for total suspended solids and total carbonaceous BOD5 is as follows. 
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7. Right-click on the Bioreactor and navigate to Output Variables > Composite Variables in 

Individual Reactors. Left-click on the mixed liquor suspended solids in individual reactors 

variable name and drag it to the Operational Performance output tab to create a new graph in this 

tab. After dragging the mlss, press Accept in the dialog box. Follow the same steps to create 

individual graphs for the following output variables from the Bioreactor object: 

• Composite Variables: total carbonaceous BOD5 in individual reactors  

• State Variables: dissolved oxygen in reactor, free and ionized ammonia in reactor  
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8. Auto arrange the graphs to fit them into the output window.  

 

9. Access the properties button for each graph and rename appropriately. Alternatively, right-click on 

a graph and select Rename Output Graph… to name a graph.  

  

10. Run the simulation at steady-state. Take a screenshot of the results in the Operational Performance 

output tab. (Exercise 3 – Question 1)  
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11. Open the Sankey Diagram and take a screenshot to record the flow profile of the continuous mixed, 

no recycle configuration. Select the OK button in the bottom-right corner of the window to close 

the Sankey diagram. (Exercise 3 – Question 2) 

12. You will now explore the effect of adding in the recycle stream from the secondary clarifier. Add 

a new scenario by navigating to Scenario > New from the simulation toolbar. Call the simulation 

“CM-recycle.” Accept the form. 

 
13. Right-click on the Secondary Clarifier and navigate to Input Parameters > Operational and drag 

the underflow rate variable from the Underflow header to the input controller area. Right-click on 

the tab and rename this new input control tab to “RAS.”  

 

 
14. Select the RAS input controls property button and set the maximum limit to 4000 m3/d. Ensure to 

Accept the form to save the changes. Set the value of the slider to 2000 m3/d and rerun the 

simulation.  
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15. Take screenshots of the results on the operational performance tab, and the Sankey diagram.  

(Exercise 3 – Question 3) 

 

Now explore the effect of modelling the bioreactor as a PFR rather than a CM reactor.  

16. In the existing model layout go to Save As… and save a copy of the model layout under a different 

name.  

17. Switch back into modelling mode. Right-click on the Bioreactor and go to Input Parameters > 

Physical. Change the number of reactors to 4. Accept this change. By default, the volume of the 

reactor (1000 m3) will be divided into 4 equal sized basins (250 m3).  

 

18. Switch into Simulation Mode. Rebuild the model when prompted.  

19. Ensure you are working in the Default Scenario. Verify that the underflow rate variable on the 

RAS input control tab is set to 2000 m3/d and run the simulation. You should now see that the 

output graphs have 4 indexes representing the individual compartments within the bioreactors.  

20. Take a screenshot of the results on the Operational Performance tab. (Exercise 3 – Question 4) 

The final reactor configuration involves the addition of step feeding to the PFR. 

21. You will now delete the old CM recycle scenario and create a new scenario for the PFR step 

feeding. In Simulation mode navigate to Scenario > Configuration from the Simulation Toolbar. 

Select the CM – Recycle scenario and click on the Delete button. Close this form.  
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22. From the simulation toolbar select Scenario > New. Select the button next to Default Scenario then 

name the new scenario to “PFR-Step Feeding.” Accept this form. 

 

Note: The input control tab that was created earlier will still be present, do not delete it. 

23. In this new scenario, right-click on the Bioreactor and navigate to Input Parameters > Operational 

and scroll down to the Internal Flow Distribution Menu. Select the influent fractions ellipse button 

and set all entries to 0.25. Make the same change to the recycle fractions. The effect of these 

adjustments is that all the incoming flow to the Bioreactor will be split evenly between each of the 

four basins.  
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24. Set the underflow rate (recycle) to 2000 m3/d from the input control slider variables tab and run 

the simulation. Record a screenshot of the effluent from the Operational Performance tab. (Exercise 

3 – Question 5)  

25. Save the model layout.  

Completion of the previous steps should have yielded snapshots of the operational performance of each 

bioreactor configuration: 

a) Complete mixed, no recycle 

b) Complete mixed, biological solids recycle  

c) Plug flow, biological solids recycle 

d) Plug flow with step-feeding, biological solids recycle 

Prepare a discussion regarding the similarities and differences of each of these configurations and suggest 

reasons for the observations. (Exercise 3 – Question 6) 

  



Exercise 4 – Plug-Flow Configuration 

34 

 

Exercise 4 – Plug-Flow Configuration  

This exercise will explore the effect of the number of tanks in the plug-flow configuration.   

1. Open the Starting Point model layout developed in Exercise 1.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. Save the Layout under a different name.  

3. Switch into Simulation Mode in not already in this mode.  

4. Select the New Table Tab button in the Outputs section of the window. In the Table Properties 

window that appears uncheck the include mass flows selection and the deselect all buttons under 

the stream choices and variable choices menus.  
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5. Select the following stream variables: 

• Stream Choices: 

i. Influent > wwinf 

ii. Bioreactor > Internal Streams, mlss 

iii. Secondary Clarifier > effluent, RAS 

• Variable Choices: 

i. Solids > TSS 

ii. Organic Variables > cBOD5 

iii. Nitrogen Variables > Ammonia Nitrogen, Nitrite and Nitrate  

iv. Other Variables > Dissolved Oxygen  
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6. Acceptance of this form will create a table on a new output tab.  

Note: If you make a mistake or desire to enter another item into the table, select the table and then the 

Properties button to access the properties menu. 

 

7. Run the simulation at steady-state. Record a screenshot of the results in the output table. (Exercise 

4 – Question 1)  

8. Beside each of the output variable names is a Create Bar Chart button. Select the button for the 

cBOD5 variable. Record a screenshot of the bar chart that appears. (Exercise 4 – Question 2) 

9. Switch back into modelling mode.  

10. Right-click on the Bioreactor and navigate to Input Parameters > Physical and change the 

number of reactors to 3. Accept this form and switch back into Simulation Mode. Rebuild the 

model when prompted.  

 

 

11. Run the simulation at steady-state and record a screenshot of the results in the output table. 

(Exercise 4 – Question 3)  

12. Switch back into modelling mode.  

13. Right-click on the Bioreactor and navigate to Input Parameters > Physical and change the number 

of reactors to 5. Accept this form and switch back into Simulation Mode. Rebuild the model when 

prompted.  
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14. Run the simulation at steady-state and record a screenshot of the results in the output table. 

(Exercise 4 – Question 4) 

15. Save the model layout.  

16. Compare the bioreactor profiles from steps 7, 11, and 14. Suggest reasoning for your observations. 

Create bar charts as needed to support your reasoning. Is each bioreactor configuration able to 

achieve the same level of nutrient removal? 
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Exercise 5 – Effect of SRT and DO Control on 

Nitrification  

The purpose of this scenario is to explore the effect of the solids retention time (SRT) and bioreactor 

dissolved oxygen (DO) concentration on the extent of nitrification.  

1. Open the Starting Point layout that was created in Exercise 1.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. Save the layout under a different name.  

3. In modelling mode right-click on the Bioreactor and navigate to Input Parameters > Physical and 

change the number of reactors to 3.  
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4. Select the Define button from the main toolbar and choose the Solids Retention Time option from 

the bottom of the list.  

 

Select the green + button to create a new SRT variable and name it “CAS.”  

• This creates a new formula: Mass()/Mass Flow().  

• The numerator will represent the mass of solids in the bioreactor, while the denominator 

will represent the mass flow of solids out of the system. To add to the numerator, simply 

left-click on the Bioreactor (the cursor changes to a hand). In the dialog box the selection 

for Reactors 1, 2, and 3 should be checked. Add to the denominator by hovering the mouse 

on the WAS stream connection point from the secondary clarifier until the cursor changes 

to an arrow, then left-click it. The equation should appear as: Mass(mlss)/Mass 

Flow(WAS). Now, hover the mouse over the clarified effluent from the secondary clarifier 

connection point until it changes to an arrow, then left-click to also add this to the 

denominator of the SRT equation. 

 

Note: If you make a mistake, use the red x button next to the green plus button to delete the 

selected srtCAS; then redo creating the SRT variable. 

 

• The final equation should appear as: Mass(mlss)/Mass Flow(effluent, WAS). Keep the 

window open. 

• Select the “Estimate WAS using set SRT” button. Close this window.  
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Note: If you require further information on setting up a new SRT variable, access the Quick Start 

Guide GPS-X Lite from the Help Menu. 

 

5. Switch into Simulation Mode. Rebuild the model when prompted.  

6. Create a new output graph and rename the graph tab to “Nitrification.”  

7. Right-click on the Bioreactor and navigate to Output Variables > Composite Variables in 

Individual Reactors. Left-click on the mixed liquor suspended solids in individual reactors 

variable name and drag to create a new graph on the Nitrification output tab.  

 

8. Right-click on the Bioreactor and navigate to Output Variables > State Variables in Individual 

Reactors. Drag the following output variables to the new graph tab.  

• Dissolved Oxygen – dissolved oxygen in reactor  

• Nitrogen Compounds – free and ionized ammonia in reactor  

• Nitrogen Compounds – nitrate and nitrite in reactor 

 

Rename each graph by accessing the property button for each graph. 
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9. From the main toolbar go to Define > Solids Retention Time and drag the srtCAS variable to the 

Nitrification output graph tab. Right-click on this new graph and select Digital from the Output 

Graph Type menu.  

 

10. Right-click on the effluent stream and go to Output Variables > State Variables. Drag the 

following variables to the same digital graph on the Nitrification tab.  

• Nitrogen Compounds – free and ionized ammonia  

• Nitrogen Compounds – nitrate and nitrite  
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11. Right-click on the mlss stream at the connection point on the top-left of the reactor, hover until the 

cursor changes to an arrow, then go to Output Variables > Composite Variables and drag the 

mixed liquor suspended solids to the digital graph.  

 

12. Auto arrange the graphs in the output tab.  
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Scenario 1 – Effect of SRT on Nitrification 

13. Create a new input control tab and rename it to “SRT.”  

14. From the Main Toolbar select Define > Solids Retention Time and drag onto the new input controls 

tab the SRT set point.  

 

15. Run the simulation at SRT set points of 2, 6, 10, and 14 days and record the values of the following 

from the Nitrification output tab: 

a. Mixed liquor suspended solids 

b. Free and ionized ammonia 

c. Nitrate and nitrite  
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Note: In the fully-functional version of GPS-X an analyze feature is available. This feature would allow 

the user to automatically run the simulation at the different SRT set points with the SRT setpoint 

presented on the x-axis rather than time.  

16. In Excel, create a graph with SRT on the x-axis, and the recorded variables from Step 15 on the y-

axis. Discuss the results. (Exercise 5 – Question 1) 

Scenario 2 – Effect of Dissolved Oxygen on Nitrification 

17. Create a new input controls tab and rename it to “DO Control.” 

18. Right-click on the Bioreactor and navigate to Input Parameters > Operational and drag onto the 

input controls area the following variables: 

• Aeration Setup – specify oxygen transfer by… 

• Diffused Aeration – distribution of air flow to aeration tank (will create 3 controls due 

to the specification of 3 tanks in the physical menu of this object) 
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19. Set the SRT set point to 5 days in the SRT input controls tab. 

20. Run the simulation at the default DO control settings and record a screenshot of the results on the 

Nitrification output tab. (Exercise 5 – Question 2)  

21. In the input controls section set the distribution of air flow to aeration tank to 0.6, 0.25, and 0.15 

for tanks 1, 2, and 3 respectively.  

 
22. Rerun the simulation and record a screenshot of the results on the Nitrification output tab. (Exercise 

5 – Question 3)  

23. In the input controls section set the distribution of air flow to aeration tank to 0.15, 0.25, and 

0.6 for tanks 1, 2, and 3 respectively. Keep the SRT Setpoint at 5 days. 

 

24. Rerun the simulation and record a screenshot of the results on the Nitrification output tab. (Exercise 

5 – Question 4)  

25. In the input controls area set the specify oxygen transfer by … to Using a DO Controller. By 

default, this will set the DO concentration in each tank to 2 mg/L. Rerun the simulation and record 

a screenshot of the results in the Nitrification output tab. Compare and contrast the results from 

steps 20, 22, and 24. (Exercise 5 – Question 5)  
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Exercise 6 – Temperature Effect on Nitrification  

Biological nitrogen removal is highly dependent on temperature; therefore, nitrogen removal is an 

important consideration in the determination of summer versus winter operating conditions.  

The objective of this exercise is to explore the effect of temperature on nitrification.  

1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. In modelling mode, define the SRT calculation. From the main toolbar select Define > Solids 

Retention Time.  

Follow the steps in Step 4 of Exercise 5. In this case, the pop-up box for the numerator will only 

have Reactor 1 specified as opposed to three reactors above. 

Also, for this exercise, make sure that the “Estimate WAS using set SRT” box is unchecked. 
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3. Right-click on the Bioreactor and navigate to Input Parameters > Physical > Volume Fractions 

More… > Local Environment Selection and set the use local settings for O2 solubility and 

biological activity to ON. This allows for access to the liquid temperature which sets the 

temperature within the Bioreactor basins.  

 

4. Switch into Simulation Mode. Rebuild the model when prompted.  

5. Create a new graph tab and call it “SRT.”  
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6. From the main toolbar navigate to Define > Solids Retention Time and drag the srtCAS variable to 

the new output tab. Right-click on the created graph and navigate to Output Graph Type > Digital.  

 

 

7. Right-click on the Bioreactor and go to Input Parameters > Physical > Volume Fractions More… 

menu and drag the liquid temperature variable to the input controls section. Rename the tab that 

is created to “Input Settings.” 

 

8. Right-click on the Secondary Clarifier and navigate to Input Parameters > Operational and drag 

the pumped flow variable to the input control Input Settings tab.  
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9. It has been stated that “The minimum SRT used to ensure nitrification at average conditions is 7 d 

at 10°C” [1].  Simulate these settings by adjusting the liquid temperature and the pumped flow 

to 10oC and 70 m3/d, respectively, in the input controls area. Run the simulation and observe the 

results. Take a screenshot of the results on the Outfall tab under the Simulation Results header. 

(Exercise 6 – Question 1)  
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10. In this exercise the SRT will be held constant to observe the effect of temperature on nitrification. 

Set the pumped flow variable to 100 m3/d (this will result in an SRT of approximately 5 days), 

and run the simulation at liquid temperatures of 20, 16, 12, 8, and 4 oC. Create a plot in Excel of 

effluent ammonia vs. liquid temperature. Ensure appropriate axis labels and title are given. 

(Exercise 6 – Question 2) 

 

Note: In the fully-functional version of GPS-X an analyze feature is available. This feature would allow 

the user to automatically run the simulation at the different bioreactor temperatures with the bioreactor 

temperature presented on the x-axis rather than time.  

11. For temperatures 16 and 4oC, determine the minimum SRT required to obtain an effluent ammonia 

concentration below 2 mgN/L. Adjust the SRT by changing the WAS pumped flow.            

(Exercise 6 – Question 3) 

12. Save the model layout. 

  

Adjust 
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Exercise 7 – Aeration Control  

In a conventional activated sludge process, good aeration control is arguably one of the most important 

factors for the removal of ammonia and organics. This exercise will explore several factors that affect 

oxygen transfer including: 

1. Equipment:  

a) Diffuser type  

b) Diffuser Density  

c) Diffuser Submergence  

2. Operations: 

a) Solids Retention Time 

b) Airflow Rate per Diffuser 

c) Diffuser Fouling  

3. Wastewater Characteristics: 

a) Temperature  

Create the following table to record answers to the questions presented in this exercise.                                

(Exercise 7 – Question 1) 

 

 Factor  Factor 

Setting 

Total Actual Oxygen 

Transfer Rate (OTR) 

(kg/d) 

Effluent 

cBOD5 

Effluent Free and 

Ionized Ammonia 

Observation 

Equipment Diffuser Type Fine 

Bubble 

651 5.53 0.359  

Coarse 

Bubble 

    

Diffuser Density 0.2 651 5.53 0.359  

0.8     

Diffuser Submergence 

(height of diffuser from 

floor) 

0.3 651 5.53 0.359  

1.2     

Operations Solids Retention Time 10 d 651 5.53 0.359  

3 d     

Total Air Flow into 

aeration tank 

20,000 

m3/d 

651 5.53 0.359  

50,000 

m3/d 

    

Diffuser Fouling 1.0 651 5.53 0.359  

0.5     

Wastewater 

Characteristics 

Temperature 20 oC 651 5.53 0.359  

10 oC     
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1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

Define the SRT calculation.  

Follow the steps in Step 4 of Exercise 5. In this case, the pop-up box for the numerator will only have 

Reactor 1 specified as opposed to three reactors above. 

• Select the “Estimate WAS using set SRT” button. Close this window.  
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2. In modelling mode right-click on the Bioreactor and navigate to Input Parameters > Physical > 

Volume Fractions More… > Local Environment Selection and set the use local settings for O2 

solubility and biological activity to ON. This allows access to the liquid temperature which sets 

the temperature within the Bioreactor basins.  

 

3. Right-click on the Bioreactor and navigate to Input Parameters > Operational > Diffused Aeration 

header and change the total air flow into aeration tank variable setting to 20,000 m3/d. 

 

4. Right-click on the Bioreactor and navigate to Input Parameters > Operational > Diffused Aeration 

More… > Standard Oxygen Transfer Efficiency (SOTE) and set the SOTE type to correlation. 
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5. Switch into Simulation Mode. Rebuild the model when prompted.  

6. Create a new scenario to explore the effect of the various factors on aeration control. Navigate to 

Scenario > New and call the new scenario “Aeration Control.” 

 

7. Create 3 input control tabs and relabel for each factor grouping: “Equipment Factors,” “Operational 

Factors”, “Wastewater Characteristics.” 

8. Select the Equipment Factors input control tab and add the following variables to the tab. 

a. Bioreactor – Input Parameters > Operational > Diffused Aeration More… > Diffused Air 

- diffuser type 
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b. Bioreactor – Input Parameters > Operational > Diffused Aeration More… > Standard 

Oxygen Transfer Efficiency (SOTE) - diffuser density (diffuser area/tank area) 

c. Bioreactor – Input Parameters > Operational > Diffused Aeration More… > Standard 

Oxygen Transfer Efficiency (SOTE) – height of diffuser from floor 

 

 

9. Select the Operational Factors input control tab and add to it the following variables: 

d. Define > Solids Retention Time > SRT set point 
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e. Bioreactor – Input Parameters > Operational > Diffused Aeration – total air into aeration 

tank 

 

f. Bioreactor – Input Parameters > Operational > Diffused Aeration More… > Diffused Air 

– fouling constant 
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10. Select the Wastewater Characteristics input controls tab and add to it the following variable: 

g. Bioreactor – Input Parameters > Physical > Volume Fractions More… > Local 

Environment Selection – liquid temperature 

 

 

11. Run the simulation and complete the previous table to explore the effect of each factor. Ensure all 

variable settings are at the default values except for the factor of interest.  

Output results for entry into the table can be found in the following locations: 

a) Total Actual Oxygen Transfer Rate (OTR) (kg/d) 

Note: Hover on the mlss stream connection point of the Bioreactor and when the cursor 

becomes an arrow right-click and select Output Variables > Total Oxygen Transfer. 
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b) Effluent cBOD5 and Effluent Free and Ionized Ammonia are found within the Outfall tab 

in the Outputs area. 
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Exercise 8 – Total Nitrogen Removal: Nitrification 

and Denitrification 

The objective of this exercise is to demonstrate how a PFR can be configured to allow for total nitrogen 

removal. 

1. Open the Starting Point layout developed in Exercise 1 and rename appropriately. 

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

  

2. In modelling mode, right-click on the Bioreactor and navigate to Input Parameters > Physical and 

change the number of tanks to 3. This change allows the bioreactor to be modelled as a PFR with 

3 equally distributed tanks.  
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3. Right-click on the Bioreactor and navigate to Input Parameters > Operational and under the 

Aeration Setup header set the specify oxygen transfer by… to Using a DO Controller. This 

change will set the DO concentration to 2 mg/L in each of the aeration tanks.  

 

4. In this same form scroll to the bottom of the window to see the Internal Flow Distribution section. 

Select the internal recycle ellipse button and set the From, To, and Flow values to 3, 1, and 0 

m3/d, respectively.  

 

5. Switch into Simulation Mode. Rebuild the model when prompted.  

6. Run the simulation at steady-state and observe the simulation outputs in the Outfall tab. Record a 

screenshot of the results under the Simulation Results header within this tab. (Exercise 8 – 

Question 1)  
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Observe the nitrogen variables and make the following observations:  

• Low ammonia concentration indicates complete nitrification  

• High nitrite and nitrate concentrations indicates incomplete denitrification  

The nitrification process converts ammonia to nitrite and nitrate in an oxygen-rich environment, 

while the denitrification process converts nitrate to nitrogen gas (N2) in the absence of oxygen.  

Select the Bioreactor output tab. Notice that the DO concentration in all three tanks is 2 mg/L, as a 

DO controller is being used to maintain this oxygen-rich environment. With no oxygen-limited 

conditions present, denitrification is constrained.  

7. Create a new scenario to explore the changes needed to allow for complete nitrogen removal. 

Navigate to Scenario > New from the simulation toolbar and call the new scenario “MLE.” 
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MLE stands for Modified Ludzack-Ettinger. In this configuration, there are two zones, anoxic and 

aerobic, and two recycles, one being the RAS stream from the Secondary Clarifier and the other an 

internal recycle stream. The internal recycle allows for more nitrate to be fed into the anoxic zone 

directly from the aerobic zone.  

 

8. Configure the PFR as an MLE system by creating an anoxic zone and specify an internal recycle 

rate. Right-click on the Bioreactor and navigate to Input Parameters > Operational >Aeration 

Control header. Select the DO setpoint ellipse button and change the DO setpoint in the first tank 

to 0 mg/L.  

 

9. Within the same window, scroll to the Internal Flow Distribution header menu. Select the internal 

recycle ellipse button and drag the internal recycle1 variable to the input controls area.  

 

10. Rename the new input controls tab to “Internal Recycle”, then select the input controls property 

button and set the max value to 10,000 m3/d. 
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11. Create a new graph output tab and rename it to “Nitrogen Variables.” Right-click on the bioreactor 

and navigate to Output Variables > State Variables in Individual Reactors. Drag the following 

Nitrogen Compound variables to the new output tab to create three new graphs: 

• Free and ionized ammonia in reactor 

• Nitrate and nitrite in reactor  

• Dinitrogen in reactor  

 

Rename each graph appropriately and auto arrange the graphs.  
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12. Run the simulation with the internal recycle set to 2000 m3/d. Record a screenshot of the Nitrogen 

Variables graphs. Discuss the results. (Exercise 8 – Question 2)  

 

13. From the input controls area select the Transfer controls to scenario button. Within this window 

select the internal recycle variable and click Accept. This change allows the internal recycle rate to 

be held at 0 m3/d and 2000 m3/d in the Default and MLE scenarios respectively.  

 

14. From the simulation toolbar navigate to Scenario > Show. This will provide a summary of the 

changes that have been made within a specific scenario. Close this window.  
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15. In Excel, create a graph of the effluent ammonia, nitrite/nitrate, TKN and TN, for internal recycle 

rates of 0, 2000, 4000, 6000, and 8000 m3/d (ie. y-axis = nitrogen variables, x-axis = internal 

recycle rates). (Exercise 8 – Question 3) 

Note: In the fully-functional version of GPS-X an analyze feature is available. This feature would allow 

the user to automatically run the simulation at the different internal recycle rates with the internal 

recycle rates presented on the x-axis rather than time.  

16. Save the model layout. 
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Exercise 9 – Exploring Kinetic Parameters 

This exercise will explore the various factors that affect the growth of heterotrophs and autotrophs, 

including review of several key kinetic parameters.  

1. Open the Starting Point model layout developed in Exercise 1.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. Save the Layout under a different name.  

3. Select the Define button from the main toolbar and choose the Solids Retention Time option from 

the bottom of the list.  

 

Follow the steps in Step 4 of Exercise 5. In this case, the pop-up box for the numerator will only have 

Reactor 1 specified as opposed to three reactors in Exercise 5. 

• Select the “Estimate WAS using set SRT” button. Close this window.  
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Note: If you require further support with setting up a new SRT variable, access the Quick Start 

Guide GPS-X Lite from the Help Menu. 

 

 

4.  Switch into Simulation Mode. Rebuild the model when prompted.   

5. Create two new input control tabs, one called “SRT” and the other “Kinetics.”  

6. To the SRT input control tab, add the following by dragging them to the tab: 

• Main toolbar - Define > Solids Retention Time > Estimate WAS using set SRT 

• Main toolbar - Define > Solids Retention Time > SRT set point 
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• Secondary Clarifier > Input Parameters > Operational > Underflow header > Underflow 

Rate 

• Secondary Clarifier > Input Parameters > Operational > Pumped Flow header > Pumped 

Flow 

 

 

7. To the Kinetics input control tab add the following by dragging: 

• Bioreactor > Input Parameters > Kinetic > Active Heterotrophic Biomass header > 

Heterotrophic Maximum Specific Growth Rate 

• Bioreactor > Input Parameters > Kinetic > Active Autotrophic Biomass header > 

Autotrophic Maximum Specific Growth Rate 
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8. Create a new graph output tab and rename it “Kinetics.” 

9. Select the Define button from the main toolbar and navigate to Solids Retention Time. Add the 

srtCAS variable to the new graph tab. Change the graph type to Digital by right-clicking on the 

graph and navigating to Output Graph Type.   

10. Right-click on the mlss stream and navigate to Output variables > State Variables > Organic 

Variables header and drag the active heterotrophic biomass variable to the new digital graph.  

11. To this digital graph also add the active autotrophic biomass variable from the same output menu. 

Auto Arrange the digital graph. 
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12. Run the simulation at steady-state for SRT set points of 2, 8, 14, and 20 days. Create a plot in 

Excel of the heterotrophic and autotrophic biomass vs. SRT and discuss the results. (Exercise 9 – 

Question 1)  

Note: In the fully-functional version of GPS-X, an analyze feature is available. This feature would 

allow the user to automatically run the simulation at the different SRT set points with the SRT set point 

presented on the x-axis rather than time.  

13. Hover over the mlss stream connection point on the bioreactor until the cursor changes to an arrow; 

then right-click on the mlss stream and navigate to Output Variables > Other Operational 

Variables and drag the RAS recycle ratio to the digital graph.  
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14. In the SRT input control tab set the use set point SRT to estimate waste flow to OFF and set the 

pumped flow variable to 100 m3/d. This sets an SRT of approximately 5 days when the underflow 

rate is set to 2000 m3/d. 

 

15. Run the simulation as underflow rates of 1000, 2000, 4000, and 8000 m3/d and record the results 

for the heterotrophic biomass, autotrophic biomass, and RAS recycle ratio. Prepare a plot in Excel 

of the heterotrophic and autotrophic biomass vs. RAS recycle ratio and discuss the results. How 

does the plot compare to the one created in Step 12? (Exercise 9 – Question 2)  

Note: In the fully-functional version of GPS-X an analyze feature is available. This feature would allow 

the user to automatically run the simulation at the different RAS recycle ratios with the RAS recycle 

ratio presented on the x-axis rather than time.  

16. Reset all of the variables in the SRT input controls tab and switch to the Kinetics input controls tab.  

17. Run the simulation with heterotrophic maximum specific growth rates of 4.8, 5.6, 6.4 and 7.2 

1/d. Prepare a plot in Excel of the effluent cBOD5 and effluent ammonia vs. the heterotrophic 

growth rate. Discuss the results. (Exercise 9 – Question 3)  
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Note: In the fully-functional version of GPS-X an analyze feature is available. This feature would allow 

the user to automatically run the simulation at the different heterotrophic growth rates with the 

heterotrophic growth rates presented on the x-axis rather than time.  

18. In the Kinetics input control reset the heterotrophic maximum specific growth rate to 6.0 1/d and 

run the simulation with autotrophic maximum specific growth rates of 0.64, 0.76, 0.88 1/d. 

Prepare a plot in Excel of the effluent cBOD5 and effluent ammonia vs. the autotrophic growth rate. 

Discuss the results and compare to those in Step 17. (Exercise 9 – Question 4)  

Note: In the fully-functional version of GPS-X an analyze feature is available. This feature would allow 

the user to automatically run the simulation at the different autotrophic growth rates with the 

autotrophic growth rates presented on the x-axis rather than time.  
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Exercise 10 – Secondary Clarifier Performance 

Having a good secondary clarifier design is critical for ensuring low effluent solids and preventing 

operational upsets such as poor sludge settling. This exercise will explore several properties of clarifiers.  

1. Open the Starting Point layout that was created in Exercise 1 

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

  

2. Save the layout under a different name.  

3. Switch into simulation mode.  

4. Create a new graph output tab and call it “Clarifier Performance.” 

Add the following output variables to a single graph on the new output tab. Right-click on the 

graph and change to Digital from the Output Graph Type dropdown. 

MLSS stream:  

• Output Variables > Composite Variables → mixed liquor suspended solids 
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Effluent Stream:  

• Output Variables > Composite Variables → total suspended solids 

 

• Output Variables > Performance Variables → TSS removal efficiency 

 

• Output Variables > Clarifier Variables → sludge blanket height  

• Output Variables > Clarifier Variables → solids loading rate  
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RAS Stream: 

• Output Variables > Composite Variables → total suspended solids 

 

 

5. Create a graph for the clarifier suspended solids in layers by right-clicking on the Secondary 

Clarifier, navigating to Output Variables > Suspended Solids, and drag the suspended solids 

variable to the Clarifier Performance output tab.  
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Right-click on the graph and change the Output Graph Type to Bar Chart (Horizontal). Rename 

the graph to “Clarifier Suspended Solids.” Auto arrange the graphs. 

 

6. Create a new input controls tab called “Clarifier Settling.” 

7. To this new input control tab, add the following: 

• Secondary Clarifier > Input Parameters > Physical > Input Required for All Types of 

Clarifiers header > Feed Point from Bottom 



Exercise 10 – Secondary Clarifier Performance 

77 

 

 

• Secondary Clarifier > Input Parameters > Settling > Use SVI to Estimate Settling 

Parameters 

• Secondary Clarifier > Input Parameters > Settling > Sludge Volume Index (SVI) 

 

• Secondary Clarifier > Input Parameters > Operational > Underflow Rate 

• Secondary Clarifier > Input Parameters > Operational > Pumped Flow 
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The secondary clarifier object has a water depth of 3 m, and a default feed point from the bottom 

of 1 m. The feed point is an important design consideration and its effect on clarifier performance 

will be explored in the following section. 

8. Run the simulation with all input control variables at their default values. Record a screenshot of 

the table and plot on the Clarifier Performance tab. (Exercise 10 – Question 1)  

9. Change the feed point from bottom variable to 0.25 m, rerun the simulation and take a screenshot 

of the results. Discuss the effect of a lower clarifier feed point. (Exercise 10 – Question 2) 
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The next section will explore the sludge volume index (SVI) parameter. This is not a physical design 

parameter but is rather a measurement of the ‘goodness’ of sludge settleability.  

10. Click on the Reset button beside the slider of the feed point from bottom variable to reset it to 

1.0 m. Set the use SVI to estimate settling parameters to ON.  

11. Run the simulation at sludge volume index (SVI) values of 50, 150, 250 mL/g, recording the 

sludge blanket height and effluent total suspended solids. (Exercise 10 – Question 3) 

 

Is a lower or higher SVI more desirable in secondary clarifier treatment? Explain your answer.  

Using state point analysis curves can be a convenient method of observing the impact of different 

MLSS operating conditions on the clarifier performance. This is made easy in GPS-X as the 

software contains a built-in state point analysis tool.  

12. Switch into modelling mode. Right-click on the secondary clarifier and navigate to Input 

Parameters > Operational > State Point Analysis Model Parameters header and switch the use 

design MLSS in state point analysis to OFF. 

 

Adjust 
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13. Accept the form and switch back into simulation mode. Rebuild the model when prompted. 

14. With all the input control variables at their default values, run the simulation at steady-state. 

(Default values: feed point- 1.0; use SVI- OFF ; sludge volume- 150; RAS underflow- 2000; WAS 

pumped- 40). 

15. Right-click on the Secondary Clarifier and navigate to Output Variables > State Point Analysis. 

This will open a new output tab with a graph for the state point analysis for the secondary clarifier. 

Record a screenshot of this graph. (Exercise 10 – Question 4) 

16. Within the input controls tab, set the pumped flow to 150 m3/d. Rerun the simulation and observe 

the effect on the state point analysis graph. Discuss the results of this adjustment to operations. 

(Exercise 10 – Question 5) 

 

17. Reset the pumped flow back to 40 m3/d and adjust the underflow rate to 4000 m3/d. Rerun the 

simulation and observe the effect of this change. Discuss the results. (Exercise 10 – Question 6) 

 

26. Reset the underflow rate back to 2000 m3/d. Set the use SVI to estimate settling parameters to 

ON and the sludge volume index (SVI) to 200 mL/g. Run the simulation and observe the impact 

of this change. Discuss the results. (Exercise 10 – Question 7) 
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Exercise 11 – Anaerobic Digestion  

The objective of this exercise is to explore the effect of various factors on the anaerobic digester 

performance including: 

a) Relationship between SRT and operating temperature  

b) Relationship between operating temperature and gas production 

 

1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. In modelling mode use the locator window to make more room at the bottom-right of the drawing 

board.  
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3. Locate the process table on the left-hand side of the Modelling window. Click on the Biosolids 

Treatment Tab, then drag an Anaerobic Digestion object and Dewatering object onto the drawing 

board.  

 

4. Click on Tools tab and drag a Sludge Disposal object onto the drawing board. Then click on the 

Flow Combiners and Splitters tab and drag a 2-Flow Combiner object onto the drawing board.  
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5. Arrange the objects as displayed in the image above. Use the Mirror and Rotate buttons on the main 

toolbar to help arrange the process objects, if necessary. 

 

6. Delete the following connection by right-clicking on the connection line and selecting Delete 

Connection: 

• Secondary Clarifier Underflow → PFR Recycle Influent  

7. Create the following connections between the process objects (an explanatory screenshot follows): 

a) Secondary Clarifier Pump → Dewatering Input 

b) Dewatering Filtrate → 2-Flow Combiner Input #2 

c) Secondary Clarifier Underflow → 2-Flow Combiner Input #1 

d) 2-Flow Combiner Output → PFR Recycle Influent 

e) Dewatering Cake → Anaerobic Digestion Input  

f) Anaerobic Digestion Overflow → Sludge Disposal Input  

 

(a) 

(b) 

(c) 

(d) 

(e) 
(f) 
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Note: Ensure the connections are exactly as specified as in the image above. 

8. Add appropriate labels to the process objects and their respective streams so the final model layout 

appears as the image below.  

 

 

 

 

 

 

 

 

 

 

 

 

Note: Depending on the sequence of placing the objects onto the drawing board, the default 

connection numbers may differ from the images above. This is not an issue; it is only important to 

ensure that your connections are between the appropriate objects as indicated below.  
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9. Right-click on the Thickener object and navigate to Input Parameters > Operational and change 

the specify solids removal by setting… to underflow and solids.  

 

10. Switch into simulation mode. 

Scenario 1 – Relationship Between Digester Operating Temperature and SRT (Exercise 11 – 

Question 1) 

11. Create a new input controls tab and rename it “Anaerobic Digestion.” 

12. Right-click on the Thickener object and navigate to Input Parameters > Operational and drag the 

pumped flow variable to the window under the new input controls tab. This variable will be used 

to control the SRT within the anaerobic digester.  

Use the properties button to set the maximum flow to 90 m3/d. 

 

pted 
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13. Right-click on the Anaerobic Digester and navigate to Input Parameters > Physical and drag the 

digester temperature to the input controls area.  

 

To maintain the same amount of solids removal while changing the digester operating temperature, 

the HRT needs to be adjusted [1]. Complete the following table through completion of the steps 

below. (Exercise 11 – Question 1) 

 

Note: The digester HRT is the same as the digester SRT in this scenario.  

Temperature 

(oC) 
HRT (d) 

Pumped Flow 

(m3/d) 

Sludge TSS 

(kg/d) 

VSS Destruction 

(%) 

18 28    

24 20    

30 14    

35 10    

14. In input controls tab set the digester temperature to 18 oC and the pumped flow to 14 m3/d and 

run the simulation.  

pted 

pted 
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15. Select the Anaerobic Digestion output tab and observe the HRT value under the Operational 

Variables header. Notice that it is at approximately 28 days due to the adjustment of the pumped 

flow variable. Record the VSS destruction and sludge TSS values in the table.  

 

16. Complete the remainder of the table through adjustment of the digester temperature and pumped 

flow rate in the Anaerobic Digestion input controls tab. You should notice that the digester 

performance remains relatively consistent, indicating that a lower operating temperature 

necessitates a higher operating HRT.  

Scenario 2 – Relationship Between Digester Operating Temperature and Gas Production 

(Exercise 11 – Question 2) 

The next section will explore the effect of the digester operating temperature on the quantity of 

methane gas production.  
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17. In the Anaerobic Digestion input controls tab set the pumped flow to 20 m3/d. Run the simulation 

at digester temperatures of 15 oC, 25 oC, and 35 oC and record the gas flow rate of methane. This 

can be approximated by simply multiplying the CH4 Content by the Total Gas Flow Rate in the 

Operational Variables section on the Anaerobic Digestion output tab.  

 

 
18. Create a graph in Excel of the Methane Gas Flow Rate vs. Digester Temperature. Discuss the effect 

that digester temperature has on the rate of methane production.  

Note: In the fully-functional version of GPS-X an analyze feature is available. This feature 

would allow the user to automatically run the simulation at the different digester temperatures 

with the digester temperature presented on the x-axis rather than time.  
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Exercise 12 – Mass Balance  

GPS-X contains a useful feature that allows users to create a Sankey Diagram for flow, solids, and nutrient 

components throughout the plant. This exercise will explore this feature to aid in understanding how the 

fate of nutrients is affected by different operational settings.  

 

1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. Follow Steps 2-9 for Exercise 11. (DO NOT change the operational parameters in the Thickener.)   
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• Select the Define button from the main toolbar and choose the Solids Retention Time 

option from the bottom of the list.  

Follow the steps in Step 4 of Exercise 5. In this case, the pop-up box for the numerator will only have 

Reactor 1 specified as opposed to three reactors above. 

• Note: Since this layout contains a Thickener, the loss of solids from the system are from 

the cake stream, rather than the WAS stream. Therefore, the equation should appear as 

Mass(mlss)/Mass Flow(effluent,cake) NOT Mass(mlss)/Mass Flow(effluent,WAS)  . 

• Ensure that the “Estimate WAS using set SRT” box in the Define window is unchecked. 
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Note: If you require further support with setting up a new SRT variable, access the Quick Start 

Guide GPS-X Lite from the Help Menu. 

 

 

3. Switch into Simulation Mode.  

4. Create a new graph output tab and rename it “SRT.” From the main toolbar go to Define > Solids 

Retention Time and drag the srtCAS variable to the SRT output graph tab. Right-click on this new 

graph and select Digital from the Output Graph Type menu.  

5. Run the simulation at steady-state and open the Sankey diagram.   

6. Under the Sankey heading at the top of the window select the color box and change the stream 

color to one of your choice.  

 

7. Observe the flow rate and mass flow of TSS, COD, and TN across the plant by selecting the 

appropriate variable from the dropdown list that appears under the Variable header. Ensure that the 

values that you observe when running the simulation at the default setting are nearly the same as 
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those presented in the table below. (Numerical simulations can produce slightly variable results 

even for the same starting information.) 

 

Variable wwinf mlss effluent WAS RAS filtrate recycle cake sludge 

Flow (m3/d) 2000 4039 1999 40 2000 38.5 2039 1.5 1.5 

TSS (kg/d) 477.8 16350 26.63 320.1 16010 15.4 16020 304.7 124.8 

COD (kg/d) 860 15580 73.58 304 15200 15.51 15220 288.5 24.53 

TN (kg/d) 80 1187 48.15 22.33 1117 1.923 1119 20.41 20.38 

 

8. Perform a mass balance on the total nitrogen (TN). Does the mass of TN into the plant (wwinf) 

equal the mass of solids out of the plant (effluent, sludge)? If not, describe the location, quantity, 

and form of nitrogen, that makes up the difference. Use simulation results to support your answer. 

(Exercise 12 – Question 1) 

9. Show that the masses of TSS and COD balance (in equals out) across the Thickener. (Exercise 12 

– Question 2) 

10. Right-click on the Secondary Clarifier and navigate to Input Parameters > Operational and drag 

the pumped flow variable to the input controls area. Rename the new input controls tab to 

“Operational Settings.”  

11. Set the pumped flow variable to 173 m3/d (SRT = 3 days) and run the steady-state simulation. 

12. Open the Sankey diagram and report the TN values in the table below. Discuss how the results 

compare to the default values. (Exercise 12 – Question 3) 

Variable wwinf mlss effluent WAS RAS filtrate recycle cake sludge 

Default - TN 

(kg/d) 

80 1187 48.15 22.33 1117 1.923 1119 20.41 20.38 

TN (kg/d)          

13. Close the Sankey window and reset the pumped flow variable.  
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14. Right-click on the Bioreactor and navigate to Input Parameters > Operational. Under the Diffused 

Aeration header drag the total air flow into aeration tank variable to the input control tab and set 

the value to 15,000 m3/d.  

 

15. Rerun the steady-state simulation and open the Sankey diagram window. Report the COD values 

in the table below and discuss how the results compare to the default values. (Exercise 12 – 

Question 4) 

Variable wwinf mlss effluent WAS RAS filtrate recycle cake sludge 

Default  -

COD (kg/d) 

860 15580 73.58 304 15200 15.51 15220 288.5 24.53 

COD (kg/d)          

16. Close the Sankey window and reset the total air flow into aeration tank back to 30,000 m3/d.  

17. Right-click on the Thickener object and navigate to Input Parameters > Operational and drag the 

removal efficiency (concentration basis) variable to the input controls section. 

18. Set the removal efficiency to 0.8, rerun the simulation and open the Sankey diagram. Report the 

TSS values in the table below and discuss how the results compare to the default values. (Exercise 

12 – Question 5) 

Variable wwinf mlss effluent WAS RAS filtrate recycle cake sludge 

Default - 

TSS (kg/d) 

477.8 16350 26.63 320.1 16000 15.4 16020 304.7 124.8 

TSS (kg/d)          
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Exercise 13 – Dynamic Operations 

The purpose of this exercise is to explore the effect of the influent flow profile on operations.  

Recreate the table below to record your answers for the following steps. (Exercise 13 – Question 1) 

Daily Average Signal Integration 

Flow Type Total 

Suspended 

Solids (mg/L) 

Total 

Carbonaceous 

BOD (mg/L) 

Free and 

Ionized 

Ammonia 

(mg/L) 

Mass Flow 

Total 

Suspended 

Solids (kg) 

Data     

Sinusoidal     

Diurnal 

Flow 

    

 

1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 
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2. In modelling mode right-click on the Influent Wastewater object and navigate to Flow > Flow Data 

and change the influent flow to 3000 m3/d.  

 

3. Right-click on the Bioreactor and navigate to Input Parameters > Operational and change the total 

air flow into aeration tank to 35,000 m3/d. 

 

4. Right-click on the Secondary Clarifier and navigate to Input Parameters > Operational and set the 

pumped flow to 100 m3/d.  
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5. Select the Define button from the main toolbar and choose the Solids Retention Time option from 

the bottom of the list. Follow the steps in Step 4 of Exercise 5. In this case, the pop-up box for the 

numerator will only have Reactor 1 specified as opposed to three reactors above. 

• Ensure that the “Estimate WAS using set SRT” button is unchecked.  

 

Note: If you require further support with setting up a new SRT variable, access the Quick Start 

Guide GPS-X Lite from the Help Menu. 
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6. From the main toolbar select Define > Daily Average. Keeping the Variable Type as Stream 

Variables select the following: 

• Stream Choices: 

i. Secondary Clarifier (effluent) > effluent  

• Variable Choices: 

i. Nitrogen Compounds (click on the +) > free and ionized ammonia 

ii. Composite Variables (click on the +)  > total suspended solids, total carbonaceous 

BOD5 

Accept the form to save the changes.  

 

 
 

7. From the main toolbar select Define > Mass Flow. Keeping the Variable Type as Stream Variables 

select the following: 

• Stream Choices: 

i. Secondary Clarifier (effluent) > effluent and WAS 

• Variable Choices: 

i. Composite Variables > total suspended solids 
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Accept the form to save the changes.  

8. From the main toolbar select Define > Totalizer. Change the Variable Type to Define Variables 

and select the following: 

i. Secondary Clarifier (effluent) > WAS > Mass Flow > Mass Flow.total suspended 

solids 

Accept the form to save the changes.  

 

9. Switch into Simulation Mode. Rebuild the model if prompted.  

10. Create a new output graph tab and rename the tab to “WWTP Performance.” Right-click on the 

WAS stream (after the cursor changes to an arrow) and navigate to Output Variables > Defined 

Variables > Totalizer and drag the Signal Integration.Mass Flow.total suspended solids variable 

to the new graph tab. Right-click on the graph that is created and go to Output Graph Type > 

Digital. Click on the Output Properties… button and change the unit of this variable to kg.  
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11. To this same digital output graph add the following: 

• Effluent Stream – Output Variables > Defined Variables > Daily Average:  Daily 

Average.total suspended solids, Daily Average.total carbonaceous BOD5, Daily 

Average.free and ionized ammonia  

 

 

12. Create 4 new X-Y output graphs in the WWTP Performance output tab. All variables are accessed 

by hovering the cursor over the appropriate connection point then right-clicking and choosing the 

designated item(s). 

• Graph 1: Bioreactor  

i. MLSS Stream – Output Variables > State Variables > active heterotrophic 

biomass, active autotrophic biomass, dissolved oxygen. Place all three variables 

on the same graph. 
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• Graph 2: SRT 

i. Define > Solids Retention Time > srtCAS 

 

• Graph 3: Effluent Quality 

i. Effluent Stream – Output Variables > Composite Variables > total suspended 

solids, total carbonaceous BOD5. Place both variables on the graph. 

ii. Effluent Stream – Output Variables > State Variables > free and ionized 

ammonia. Drag this variable to the plot area. 
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• Graph 4: Influent Flow  

i. wwinf steam – Output Variables > Flow > flow  
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Auto arrange the graphs and rename them appropriately.  

 

13. Create a new input controls tab and rename it to “Operational Settings.” 

14. Right-click on the Influent Wastewater object and navigate to Flow > Flow Data. Drag the flow 

type variable to the input controls tab.  
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15. Within this same form select the Other Flow Options More… form and under the Sinusoidal header 

drag the sine wave frequency and the amplitude scaling factor to the input controls tab.  
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In the following steps you will record screenshots of the outputs graphs. Select the Bioreactor graph 

under the WWTP Performance tab. Open the graph’s properties window to adjust the autoscale and 

axes as shown in the screenshot below.  

 

 

 

16. In the Simulation Toolbar set the Stop Time to 1-day. With the input controls at the default settings, 

run the simulation at steady state. Report the results in the first row of the table. Record a screenshot 

of the output graphs. (Exercise 13 – Question 1) 

17. In the Operational Settings tab, change the flow type to Sinusoidal, the sine wave frequency to 

2.0 1/d and the amplitude scaling factor to 0.5.  

 

18. Run the simulation for 1-day at steady-state and report the values in the 2nd row of the table. Record 

a screenshot of the output graphs. (Exercise 13 – Question 2) 

19. In the Operational Settings tab change the flow type to Diurnal Flow Factor and run the simulation 

for 1-day at steady-state and report the values in the table. Record a screenshot of the output graphs. 

(Exercise 13 – Question 3) 

20. Prepare a discussion regarding the following questions (Exercise 13 – Question 4): 

• How are the daily average TSS, total cBOD5, NH3, and mass flow of solids affected by the 

flow type? 

• Compare the dynamic vs. instantaneous solids retention time between each flow type.  

Uncheck the 

autoscale box 
Unlock the axis 

Set the axis 

range 
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• How is the concentration of heterotrophic and autotrophic biomass affected by the flow 

type? 
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Exercise 14 – Aeration Strategy on Plant 

Performance and Energy 

As observed in Exercise 7, aeration control has a strong impact on the plant performance. The objective of 

this exercise is to better understand the effect of the dissolved oxygen concentration in the aeration basin 

on plant performance.  

1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. In modelling mode right-click on the Secondary Clarifier and navigate to Input Parameters > 

Operational and change the pumped flow to 100 m3/d. 
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3. Right-click on the Bioreactor and navigate to Input Parameters > Operational and under the 

heading “Aeration Setup” change the specify oxygen transfer by… to Using a DO Controller.  

 

4. From the Define menu on the main toolbar select Daily Average.  

 

5. With the Variable Type set at Stream Variables make the following selections: 

• Stream Choices: 

i. Secondary Clarifier (effluent) > effluent 

• Variable Choices: 

i. Nitrogen Compounds > free and ionized ammonia 

ii. Composite Variables > total carbonaceous BOD5 
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6. Accept this form and switch into simulation mode. Rebuild the model if prompted. 

7. Create a new input controls tab and rename it to “DO Control.” 

8. Right-click on the Bioreactor and navigate to Input Parameters > Operational > Aeration Control 

header and drag the DO setpoint variable to the input controls area. 
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9. Create a new output graph tab called “Performance Variables” and add to it 3 new graphs. To access 

the designated variables, go to the connection point, hover until the cursor become an arrow, then 

right-click to access the menu.  

• Effluent Stream – Output Variables > State Variables > Free and Ionized Ammonia 

 

• Effluent Stream – Output Variables > Composite Variables > Total Carbonaceous BOD5 

 

• MLSS Stream – Output Variables > State Variables > Dissolved Oxygen  
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Rename the graphs appropriately. 

10. Additionally, within this tab, add the Daily Average values as follows. Right-click on the effluent 

stream when the cursor changes to an arrow and navigate to Output Variables > Defined Variables 

> Daily Average and drag the Daily Average.total carbonaceous BOD5 to the Performance 

Variables tab. Drag the Daily Average.free and ionized ammonia variable to this same graph. 

Change the graph type to Digital by right-clicking on the graph and navigating to Output Graph 

Type.  

11. Right-click on the mlss stream and navigate to Output Variables > Operating Cost and drag the 

cumulative blower energy cost variable to the existing digital output graph.  

12. Auto arrange the graphs.  
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The following sections will explore the effect of 2 scenarios on DO control and plant performance.  

Scenario 1 – Continuous vs. Intermittent Aeration  

 

To simulate the effect of intermittent aeration an input file can be created.  

 

13. Right-click on the DO setpoint variable in the input controls section and select Data File… from 

the dropdown menu. This will open a window where you can set the value of the DO setpoint at 

user-specified time steps.  

 

14. Create the following input in the data file. The value specified at t = -1 days is the steady-state DO 

setpoint.  
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15. Accept this form and save the data file in an appropriate location.  

16. Adjust the DO Setpoint controller settings. Right-click on the Bioreactor and navigate to Input 

Parameters > Operational > Aeration Control > More … and drag the proportional gain and 

integral time variables to the input controller tab. 
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17. Set the proportional gain and integral time to 25.0 and 0.001 d, respectively.  

 

18. In the simulation toolbar increase the stop time to 1 day and run the simulation. Record a screenshot 

of the results on the Performance Variables output tab. (Exercise 14 – Question 1) 

19. Select the Input Control Properties… button and change the DO setpoint controller type from File 

Input to Slider. Accept the form. In the Input control window set the DO setpoint to 2.0 mg/L. 

 

20. With the Stop Time at 1 day run the simulation. Report the values for the daily average effluent 

cBOD5 and ammonia concentrations, and the cumulative blower energy cost. Compare the results 

with those obtained from intermittent aeration. In your opinion is the extra cost of constant aeration 

worth it? (Exercise 14 – Question 2) 

 

Scenario 2 – Effect of DO Setpoint on Aeration Energy Usage  

 

21. In the input control, set the DO setpoint to 5 mg/L and run the simulation with a stop time of 0-

days. (No values will appear in the X-Y graphs.) 
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22. Open the Energy Usage Summary window. Record a screenshot of the Layout View with the 

Aeration Power variable selected from the banner at the top of the window. (Exercise 14 – 

Question 3) 

23. Switch to the Table/Pie View tab at the top of the Energy Usage Summary window and select the 

Layout Total row. Record a screenshot of the resulting Layout Total Pie Chart. (Exercise 14 – 

Question 4) 

24. Close the Energy Usage Summary window by clicking “OK” and select the Outfall output tab and 

report the value for the plant effluent cBOD5 and ammonia. (Exercise 14 – Question 5) 

25. Repeat steps 21 – 24 for a DO setpoint of 0.5 mg/L. Compare the results with use of a DO setpoint 

of 5.0 mg/L and 0.5 mg/L. (Exercise 14 – Question 6) 
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Exercise 15 – Model Calibration 

Modelling can provide a valuable tool for the exploration of a plant’s performance and how it is affected 

by various operational settings. Although the default parameter settings in the GPS-X models are based on 

highly reviewed literature values, it is always necessary to perform a calibration to improve the fit of actual 

and model-predicted values as parameters can differ between plants.  

1. Open the Starting Point model layout developed in Exercise 1 and save it under a different name.  

Note: If you ran into any trouble with configuring the layout in Exercise 1, it can be accessed from 

the main toolbar by going to File > Sample Layouts… 

 

2. In modelling mode, right-click on the Bioreactor and navigate to Input Parameters > Operational 

and under the Diffused Aeration heading adjust the total air flow into aeration tank to 35,000 

m3/d. 
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3. Right-click on the Secondary Clarifier and navigate to Input Parameters > Settling and switch the 

use SVI to estimate settling parameters to ON.  

 

4. Switch into Simulation Mode. Rebuild the model if prompted.  

5. Create a new output graph tab and rename it to “Calibration.” To this tab, you will add four new 

graphs.  

6. Hover on the connection point for the wwinf stream and when the cursor changes to an arrow right-

click. Navigate to Output Variables > Flow and drag the flow variable to the output tab.  

 

7. Right-click on the cursor changed to an arrow at the connection point for the mlss stream and 

navigate to Output Variables > Composite Variables and drag the mixed liquor suspended solids 

variable to the Calibration output tab.  
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8. Right-click on cursor arrow shape on the mlss stream and navigate to Output Variables > State 

Variables and drag the dissolved oxygen variable to the same output tab.  

 

9. Right-click on the cursor arrow shape at the connection point for the effluent stream and navigate 

to Output Variables > Composite Variables and drag the total suspended solids variable to the 

same output tab.  
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10. Rename the graphs appropriately and auto arrange in the output tab. 

 

The next section of this exercise involves the creation of a data file.  

11. Open a new excel file and enter the following information: 
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• Row 1 contains the cryptic variable name of each parameter 

o qconwwinf is the influent flow variable (input) 

o xmlss is the mixed liquor suspended solids concentration (output) 

o somlss is the dissolved oxygen concentration in the mlss stream (output) 

o xeffluent is the total suspended solids concentration in the effluent stream 

(output) 

Note: You can verify these cryptic variable names by hovering your mouse over 

the variable name in GPS-X. Below is an example of this for the influent flow 

variable. 

 

• Row 2 contains the measurement unit for each variable 

• Row 3 contains the steady-state value of each variable 

• Rows 4 – 9 contain the dynamic value of each variable 

12. Save this excel file in an appropriate location.  

Since the influent flow to the WWTP is an input in the data file, it needs to be added to the input 

controls area, so it can be automatically adjusted over the 1-day simulation window.  

13. Right-click on the Influent Wastewater object and navigate to Flow > Flow Data and drag the 

influent flow variable to the input controls area. Rename the input tab to “Calibration Settings.” 
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14. In GPS-X Lite from the Simulation Toolbar navigate to Scenario > Configuration and select the 

Data Files button.  

 

15. Select the Add… button and add the excel file that you previously created in Step 11. Once you 

accept this form you should notice that the influent flow variable in the input controls section 

changes from a slider-type to a file input-type controller.  
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16. Set the Stop Time to 1-day and run the simulation at steady-state. Record a screenshot of the graphs 

on the Calibration output tab. (Exercise 15 – Question 1) 

You should notice that the actual values (points on the graph) and the simulation results (line) 

do not align. You will now explore the process of manually making changes to plant operations 

to improve the fit between the actual and simulation values.  

We will look at adjusting 3 parameters to improve the calibration: 

a) WAS pumped flow rate → A higher wastage rate decreases the MLSS concentration 

in the bioreactor 

b) Sludge Volume Index (SVI) → A lower SVI reflects improved clarifier settling 

allowing for lower effluent suspended solids  

c) Diffuser Fouling Constant → Increased fouling decreases the concentration of 

dissolved oxygen in the bioreactor 

17. To the input controls area add the following: 

• Secondary Clarifier – Input Parameters > Operational > pumped flow 

 

• Secondary Clarifier – Input Parameters > Settling > sludge volume index (SVI) 
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• Bioreactor – Input Parameters > Operational > Diffused Aeration More…> fouling constant 

 

 

18. Start by adjusting the pumped flow variable to 60 m3/d and run the simulation for 1-day.  
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You should notice that this pumped flow value causes the simulated MLSS concentration to 

decrease below the actual values on the output graph. 

19. Continue to adjust the pumped flow variable to approximately match the actual bioreactor mlss 

concentration. Record the value of the pumped flow. (Exercise 15 – Question 2) 

20. Next, adjust the sludge volume index (SVI) variable to 100 mL/g and rerun the simulation. Keep 

the pumped flow value at the appropriate setting that you determined in Step 19. 

You should notice that this change helps to decrease the effluent TSS value.  

21. Continue to adjust the sludge volume index (SVI) variable to approximately match the effluent TSS 

concentration. Record the value of the SVI. (Exercise 15 – Question 3) 

22. Lastly, adjust the fouling constant to 0.95 and rerun the simulation. Keep the pumped flow value 

and sludge volume index value at the settings you determined in steps 19 and 21 respectively. 

You should notice that this helps to align the actual and model-predicted dissolved oxygen 

concentration in the bioreactor.  

23. Continue to adjust the fouling constant to approximately match the bioreactor dissolved oxygen 

concentration. Record the value of the fouling constant (Exercise 15 – Question 4) 

Adjustment of some of these parameters impacts more than one output parameter. For example, 

improving the secondary clarifier settling by lowering the SVI not only decreases the solids in the 

effluent but also increases the bioreactor mlss concentration.  

24. Make further changes to the 3 calibration parameters until you are satisfied with the fit between the 

actual and model-predicted results. Record the values of each parameter setting and the results of 

the output graphs. (Exercise 15 – Question 5) 

Once you have calibrated the parameter settings you can add them to the model layout, so they will 

appear in modelling mode, and as the base values in the Default Scenario in simulation mode. This 

will be done as follows. 

25. Select the Transfer Values to Layout button in the Input Controls section. In the form that appears 

click on the checkmark button to select all items to be transferred to the layout.  

Once accepting this form, you will have to confirm that you want to transfer the values to the 

layout as this will result in a rebuild of the model. 
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A useful tool in GPS-X is the ability to conduct statistical analysis on graphical outputs.  

26. Run the simulation for 1-day. Right-click on the dissolved oxygen graph and select Statistics > 

dissolved oxygen from the available menu.  

 

27. From the window that appears, under “Model Fit Evaluation” select the plot of simulation vs 

measured and under “Residual Analysis” select residuals. Accept this form.  
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28. Two graphs appear. Separate them by clicking on one and moving it. Record screenshots of the two 

statistics graphs. (Exercise 15 – Question 6) 
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APPENDIX A: A Brief Discussion of Biotreatment 

Models in GPS-X™ (Lite) 

This section provides additional information regarding the activated sludge and digestion model provided 

in GPS-X Lite. Theory and Practice of Water and Wastewater Treatment, 2nd ed. by Droste and Gehr is a 

complimentary text book to GPS-X Lite. The textbook which is geared to present the fundamentals of 

biotreatment (and other processes) at an undergraduate or first graduate course level uses some 

simplifications leading to some differences when compared to more advanced models with various 

refinements available in GPS-X Lite. This section will also describe the major differences between the 

biological models used in GPS-X Lite and the textbook models. 

The commercial version of GPS-X offers the user a choice from many advanced and custom models for 

various wastewater treatment processes as well as a host of analytical tools. The discussion here will be 

confined to the two models supporting the textbook. 

Consult the Technical Reference for GPS-X under the Help-Manual tab for further information. 

Activated Sludge Model 

As noted in the GPS-X manual for the application related to the textbook, GPS-X Lite implements the 

International Water Association (IWA) activated sludge model 1 (ASM1) which was the first of the more 

principled models developed under the aegis of the IWA. This model made significant improvements over 

historical approaches in describing aerobic suspended growth processes. 

The ASM1 matrix is presented in Table 1. Compare it to Table 17.9 in the textbook. The advanced C-N 

model in the text, as noted in the text, has some simplifications to make the model algebraically manageable; 

of course, GPS-X with its numerical engine does not suffer any limitations of this nature. The most 

significant differences in the two models are as follows. 

RATE EXPRESSIONS 

In ASM1, the specific growth rate of heterotrophs includes a term for oxygen dependence. 

S O
H Hm

S S OH O

S S

K S K S
 =

+ +
 

A typical value for KOH is 0.2 mg/L At the minimum dissolved oxygen (DO) concentration of 2 mg/L 

recommended for an aerobic treatment process, the value of the oxygen hyperbolic expression is 0.91 and 

it approaches 1 at higher DO concentrations. 
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The anoxic heterotrophic growth expression contains the term, OH

OH O

K

K S+
, which is known as a “switching 

function” to turn it off and off in aerobic and anoxic conditions, respectively. Ideally, anoxic conditions 

should have zero DO (there is no aeration supplied in an anoxic tank, only incidental oxygen transfer at the 

water surface). For SO = 0, the value of the switching function is 1.0. 

Growth rate of autotrophs is also mediated by a hyperbolic DO expression.  

HYDROLYSIS RATE EXPRESSION 

See the note below Table 17.6 in the text. The ASM1 expression is more versatile and will yield better 

results. 

ENDOGENOUS DECAY 

ASM1 uses a death-regeneration approach to endogenous decay. In fact, the endogenous decay rate 

coefficient is a die-off coefficient. The degradable part of decayed microorganisms are simply rendered as 

XS (degradable particulate matter). Concomitantly, degradable particulate organic nitrogen (in XND) is 

generated. The degradable particulates are hydrolysed to soluble degradable organics (SS) and then 

metabolized to complete the death-regeneration cycle. Hydrolysis of degradable particulates also results in 

release of soluble organic nitrogen discussed below. 

The text uses a net decay approach for endogenous decay (this approach was adopted in a later IWA model, 

ASM3). Endogenous decay simply results in the oxidation of the degradable portion of microorganisms. 

The endogenous decay incorporates metabolism kinetics resulting in the net loss of the degradable portion 

of microorganisms. 

NITROGEN AND PHOSPHORUS 

In ASM1, additional nitrogen processes are necessitated by the endogenous decay-regeneration approach. 

In ASM1, the particulate organic nitrogen (Kjeldahl N, XND) generated from endogenous decay is converted 

to soluble organic nitrogen (SND) at the rate of hydrolysis of degradable particulates according to process 8. 

The rate of XND transformation depends on the ratio of XND to XS. Hydrolysis of soluble degradable organic 

nitrogen produced from endogenous decay to ammonia is another process.  

In the text, nitrogen yielded from endogenous decay of biomass is assumed to be released as ammonia.  

ASM1 is not concerned with phosphorus; it is considered an inert entity in ASM1. 

OTHER MINOR DIFFERENCES 

ASM1 tracks nondegradable particulates in the influent (XI) separately from those produced by endogenous 

decay (Xp). 
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ASM1 includes alkalinity transformations (SAlk) for aerobic and anoxic growth. 
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Table 1. IWA ASM1: Process kinetics and stoichiometry for carbon oxidation, nitrification, and denitrification  

Component → i 1 2 3 4 5 6 7 8 9 10 11 12 13 Process Rate, j [ML−3T−1] 

j Process   SI SS XI XS XH XA XP SO SNOX SNH SND XND SAlk  

1 Aerobic 

growth of 

heterotrophs 

 

H

1

Y
−  

  1   
H

H

1 Y

Y

−
−  

 −iNBM   
XB

14

i
−  S O

Hm H

S S OH O
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K S K S


  
  
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2 Anoxic 

growth of 

heterotrophs 

 

H

1

Y
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H

H

1
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Y

Y

−
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3 Aerobic 
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4 Decay of 

heterotrophs 

   1−fXI −1  fXI     iXBM−fXI

iXP 

 bHXH 

5 Decay of 

autotrophs 

   1−fXI  −1 fXI     iXBM−fXI

iXP 

 bAXA 

6 Ammonifica-

tion of soluble 

organic 

nitrogen 

         1 −1  1

14
 kaSNDXH 

7 Hydrolysis of 

entrapped 

organics 
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8 Hydrolysis of 

entrapped 

organic 

nitrogen 

          1 −1  7(XND/XS) 
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Anaerobic Treatment Model 

The anaerobic digestion model, MantisAD, provided in GPS-X Lite is a simpler version of anaerobic 

digestion model no. 1 (ADM1) which is the most advanced anaerobic digestion model (requiring a plethora 

of data for calibration and implementation and beyond the scope of the textbook). The degradation scheme 

of organic material and N- transformations are as shown in Figures 1 and 2. The model (22 state variables, 

13 processes plus chemical and gas exchange) assumes that the disintegration of composite particulate 

organic material results in the production of both slowly and readily biodegradable particulate material. 

This particulate material then undergoes hydrolysis resulting in the production of soluble material that is 

also slowly and readily biodegradable. This soluble material is then fermented to acetate and hydrogen 

which is subsequently converted to methane gas. Four biomass types (slowly and readily biodegradable 

substrate degraders, acetate utilizing methanogens, and hydrogen utilizing methanogens) mediate the steps 

and are subject to various pH, ammonia, and hydrogen inhibitions. 

 

Figure 1 Anaerobic Transformation of Organic Material in Digester 

The matrix describing the major metabolic phenomena in the anaerobic digestion model (MantisAD) in 

GPS-X Lite is given in Table 2 (see Copp et al. 2005) for comparison to the advanced anaerobic digestion 

model in Table 19.3. It is readily observed that the GPS-X Lite model uses concepts developed in the text 

but implements them differently from the model in Table 19.3. The model implemented in GPS-X Lite is 
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Particulate Material 
Rapidly Biodegradable 

Particulate Material 

Inert Material 
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geared for anaerobic digestion of solids produced in primary clarifiers and aerobic biotreatment processes 

and it easily integrates with these processes in an overall treatment plant model.  

Definitions of parameters in the MantisAD model are given in Tables 3-5. In the model, particulate matter 

is separated into slowly (XSs) and rapidly (XSr) degradable particulate matter. Soluble products of hydrolysis 

are slowly (SSs) and rapidly (SSr) degradable substrate which are each metabolized into acetate and 

hydrogen. Acetoclastic and hydrogenotrophic methanogens then metabolize these products into methane. 

Endogenous decay renders the decayed groups of bacteria as composite particulate matter. MantisAD also 

provides a more detailed approach to modelling nitrogen as shown in Figure 2 and the matrix. 

 

Figure 2 Anaerobic Transformation of Nitrogen in Digester 

 

 

 

 

 

 

 

 

Inert Organic Nitrogen 

Ammonia 

Particulate Organic 

Nitrogen 

Soluble Organic 

Nitrogen 

Biomass Associated 

Nitrogen 



Anaerobic Treatment Model 

132 

 

Table 2 MantisAD anaerobic digester model 

Component →         i 1 2 3 4 5 6 7 8 9 10 11 12 13 14 

j Process   𝑋𝐼  𝑆𝐼 𝑋𝑏𝑠  𝑋𝑏𝑟  𝑋𝐴𝑐  𝑋𝐻2 𝑋𝐶  𝑋𝑠𝑏 𝑋𝑟𝑏  𝑆𝑠𝑏 𝑆𝑟𝑏 𝑆𝐴𝑐  𝑆𝐻2 𝑆𝐶𝐻4 

1 Disintegration 𝑌𝑋𝐼  𝑌𝑆𝐼     -1 𝑌𝑠𝑏  1 − 𝑌𝑋𝐼 − 𝑌𝑆𝐼 − 𝑌𝑆𝑏      

2 
Hydrolysis of readily 

hydrolysable material 
        -1  1    

3 
Hydrolysis of slowly 

hydrolysable material 
       -1  1     

4 

Uptake of readily 

biodegradable 

substrate 

   𝑌𝑏𝑟       -1 𝑌𝐴𝑐𝑟𝑏(1 − 𝑌𝑏𝑟) (1 − 𝑌𝐴𝑐𝑟𝑏)(1 − 𝑌𝑏𝑟)  

5 

Uptake of slowly 

biodegradable 

substrate 

  𝑌𝑏𝑠       -1  𝑌𝐴𝑐𝑠𝑏(1 − 𝑌𝑏𝑠) (1 − 𝑌𝐴𝑐𝑠𝑏)(1 − 𝑌𝑏𝑠)  

6 Uptake of acetate      𝑌𝐴𝑐       -1  1 − 𝑌𝐴𝑐  

7 Uptake of Hydrogen       𝑌𝐻2       -1 1 − 𝑌𝐻2 

8 
Organic nitrogen 

hydrolysis 
              

9 Ammonification               

10 
Endogenous decay of 

slow degraders 
  −    1        

11 
Endogenous decay of 

rapid degraders 
   -1   1        

12 

Endogenous decay of 

hydrogenotrophic 

methanogens 

    -1  1        

13 

Endogenous decay of 

acetoclastic 

methanogens 

     -1 1        
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Table2 continued. 

Component →         i 15 16 17 18 19 20 21 Process Rate 

j Process   𝑆𝐼𝐶  𝑆𝐼𝑁  𝑋𝑁𝑏 𝑋𝑁𝐼  𝑎𝑑𝑆𝑁𝐼 𝑎𝑑𝑆𝑁𝑑 𝑎𝑑𝑋𝑁𝑑  j [ML−3T−1] 

1 Disintegration 
𝐶𝑋𝑐 − 𝑌𝑆𝐼𝐶𝑆𝐼 − 𝑌𝑋𝐼𝐶𝑋𝐼 − 𝑌𝑠𝑏𝐶𝑋𝑠𝑏 −

(1 − 𝑌𝑋𝐼 − 𝑌𝑆𝐼 − 𝑌𝑠𝑏)𝐶𝑋𝑟𝑏  
  𝑌𝑋𝐼𝑌𝑋𝑁𝐼 𝑌𝑆𝐼𝑌𝑆𝑁𝐼 −𝑌𝑋𝐼𝑌𝑋𝑁𝐼 − 𝑌𝑆𝐼𝑌𝑆𝑁𝐼  𝐾𝑑𝑖𝑠𝑋𝐶  

2 
Hydrolysis of readily 

hydrolysable organics 
𝐶𝑋𝑟𝑏 − 𝐶𝑆𝑟𝑏   

   
 𝐾ℎ𝑦𝑑𝑟ℎ𝑋𝑟𝑏 

3 
Hydrolysis of slowly 

hydrolysable organics 
𝐶𝑋𝑠𝑏 − 𝐶𝑆𝑠𝑏   

   
 𝐾ℎ𝑦𝑑𝑠ℎ𝑋𝑠𝑏  

4 
Uptake of readily 

biodegradable substrate 

𝐶𝑆𝑟𝑏 − 𝑌𝑏𝑟𝐶𝑏𝑖𝑜 − 𝑌𝐴𝑐𝑟𝑏(1

− 𝑌𝑏𝑟)𝐶𝑆𝐴𝑐  
−𝑌𝑏𝑟𝑌𝑁𝑋𝐵  𝑌𝑏𝑟𝑌𝑁𝑋𝐵 

   
 

𝜇𝑋𝑏𝑟𝑆𝑟𝑏
𝐾𝑆𝑟𝑏 + 𝑆𝑟𝑏

𝑋𝑏𝑟𝜈4 

5 
Uptake of slowly 

biodegradable substrate 

𝐶𝑆𝑠𝑏 − 𝑌𝑏𝑠𝐶𝑏𝑖𝑜 − 𝑌𝐴𝑐𝑠𝑏(1

− 𝑌𝑏𝑠)𝐶𝑆𝐴𝑐  
−𝑌𝑏𝑠𝑌𝑁𝑋𝐵  𝑌𝑏𝑠𝑌𝑁𝑋𝐵 

   
 

𝜇𝑋𝑏𝑠𝑆𝑠𝑏
𝐾𝑆𝑠𝑏 + 𝑆𝑠𝑏

𝑋𝑏𝑠𝜈5 

6 Uptake of acetate  𝐶𝑆𝐴𝑐 − 𝑌𝐴𝑐𝐶𝑏𝑖𝑜 − (1 − 𝑌𝐴𝑐)𝐶𝑆𝐶𝐻4 −𝑌𝐴𝑐𝑌𝑁𝑋𝐵  𝑌𝐴𝑐𝑌𝑁𝑋𝐵  
   

 
𝜇𝑋𝐴𝑐𝑆𝐴𝑐

𝐾𝑆𝐴𝑐 + 𝑆𝐴𝑐
𝑋𝐴𝑐𝜈6 

7 Uptake of Hydrogen  −𝑌𝐻2𝐶𝑏𝑖𝑜 − (1 − 𝑌𝐻2)𝐶𝑆𝐶𝐻4 −𝑌𝐻2𝑌𝑁𝑋𝐵  𝑌𝐻2𝑌𝑁𝑋𝐵  
   

 
𝜇𝑋𝐻2𝑆𝐻2
𝐾𝑆𝐻2 + 𝑆𝐻2

𝑋𝐻2𝜈7 

8 
Organic nitrogen 

hydrolysis 
   

  
1 -1 𝐾𝑑𝑖𝑠𝑎𝑑𝑋𝑁𝑑 

9 Ammonification  1  
  

-1  (𝐾ℎ𝑦𝑑𝑟𝑏𝑋𝑟𝑏 +𝐾ℎ𝑦𝑑𝑠𝑏𝑋𝑠𝑏)
𝑎𝑑𝑆𝑁𝑑

𝑋𝑟𝑏+𝑋𝑠𝑏
  

10 
Endogenous de-cay of 

slow degraders 
𝐶𝑏𝑖𝑜 − 𝐶𝑋𝑐  

 
−𝑌𝑁𝑋𝐵 

   
𝑌𝑁𝑋𝐵 𝑏ℎ𝑋𝑏𝑠 

11 
Endogenous decay of 

rapid degraders 
𝐶𝑏𝑖𝑜 − 𝐶𝑋𝑐  

 
−𝑌𝑁𝑋𝐵 

   
𝑌𝑁𝑋𝐵 𝑏ℎ𝑋𝑏𝑟 

12 

Endogenous decay of 

hydrogenotrophic 

methanogens 

𝐶𝑏𝑖𝑜 − 𝐶𝑋𝑐  

 

−𝑌𝑁𝑋𝐵 

   

𝑌𝑁𝑋𝐵 𝑏ℎ𝑋𝐴𝑐  

13 

Endogenous decay of 

acetoclastic 

methanogens 

𝐶𝑏𝑖𝑜 − 𝐶𝑋𝑐  

 

−𝑌𝑁𝑋𝐵 

   

𝑌𝑁𝑋𝐵 𝑏ℎ𝑋𝐻2 
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Notes on Table 2. 

Soluble CO2 and inert inorganic solids are also state variables tracked by MantisAD but they are not listed 

in the table due to space limitations. 

Rates 4-7 include inhibition terms (i) that are function of pH, unionized ammonia, and hydrogen; see Copp 

et al. (2005) for details.  

The model calculates pH and gas transfer from the liquid phase to the gaseous phase. Thus, the initially 

soluble methane (SCH4) produced leaves in both the gas exiting the reactor as well as the liquid effluent. 

Carbon dioxide and hydrogen also exit by both routes.  

Table 3 State Variables in MantisAD 

Variable Symbol Units 

Inert inorganic suspended solids 𝑋𝐼𝐼  mg/L 

Inert organic suspended solids  𝑋𝐼  mg COD/L 

Inert soluble COD  𝑆𝐼  mg COD/L 

Biomass growing on slowly biodegradable material  𝑋𝑏𝑠  mg COD/L 

Biomass growing on readily biodegradable material  𝑋𝑏𝑟  mg COD/L 

Acetate degraders  𝑋𝐴𝑐  mg COD/L 

Hydrogen degraders  𝑋𝐻2  mg COD/L 

Composite material  𝑋𝐶  mg COD/L 

Slowly hydrolysable particulate material  𝑋𝑠𝑏  mg COD/L 

Readily hydrolysable particulate material  𝑋𝑟𝑏  mg COD/L 

Slowly biodegradable soluble material  𝑆𝑠𝑏  mg COD/L 

Readily biodegradable soluble material  𝑆𝑟𝑏  mg COD/L 

Acetate  𝑆𝐴𝑐  mg COD/L 

Hydrogen  𝑆𝐻2  mg COD/L 

Methane  𝑆𝐶𝐻4  mg COD/L 

Ammonia  𝑆𝐼𝑁  mg N/L 

Biomass associated nitrogen  𝑋𝑁𝑏  mg N/L 

Inert organic particulate nitrogen  𝑋𝑁𝐼  mg N/L 

Inert organic soluble nitrogen  𝑎𝑑𝑆𝑁𝐼  mg N/L 

Organically bound soluble nitrogen  𝑎𝑑𝑆𝑁𝑑  mg N/L 

Organically bound particulate nitrogen  𝑎𝑑𝑋𝑁𝑑  mg N/L 

Inorganic carbon  𝑆𝐼𝐶  mole/L 

 

When using the MantisAD model together with ASM1 model, the phosphorus is considered an inert entity 

in MantisAD and its reactions are disabled.  
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Table 4 Stoichiometry Constants in MantisAD 

Parameter Symbol Unit 

Readily biodegradable biomass yield 𝑌𝑏𝑟 g COD/g COD 

Slowly biodegradable biomass yield 𝑌𝑏𝑠 g COD/g COD 

Acetate degraders biomass yield 𝑌𝐴𝑐 g COD/g COD 

Hydrogen degraders biomass yield 𝑌𝐻2 g COD/g COD 

Yield of particulate inert material from composite material 𝑌𝑋𝐼 g COD/g COD 

Yield of soluble inert material from composite material 𝑌𝑆𝐼 g COD/g COD 

Yield of slowly biodegradable material from composite material 𝑌𝑠𝑏 g COD/g COD 

Acetate yield from readily biodegradable substrate 𝑌𝐴𝑐𝑟𝑏 g COD/g COD 

Acetate yield from slowly biodegradable substrate 𝑌𝐴𝑐𝑠𝑏 g COD/g COD 

Fraction of hydrolysed nitrogen becoming particulate inert nitrogen 𝑌𝑋𝑁𝐼  g N/g N 

Fraction of hydrolysed nitrogen becoming soluble inert nitrogen 𝑌𝑆𝑁𝐼  g N/g N 

Fraction of ammonia becoming associated with the biomass 𝑌𝑁𝑋𝐵 g N/g N 

Composites carbon content   𝐶𝑋𝑐 mole C/g COD 

Soluble inerts carbon content             𝐶𝑆𝐼  mole C/g COD 

Particulate inerts carbon content         𝐶𝑋𝐼  mole C/g COD 

Readily hydrolysable particulate material carbon content 𝐶𝑋𝑟𝑏 mole C/g COD 

Slowly hydrolysable particulate material carbon content 𝐶𝑋𝑠𝑏 mole C/g COD 

Soluble readily biodegradable carbon content              𝐶𝑆𝑟𝑏 mole C/g COD 

Particulate slowly biodegradable carbon content              𝐶𝑆𝑠𝑏 mole C/g COD 

Acetate carbon content              𝐶𝑆𝐴𝑐 mole C/g COD 

Methane carbon content      𝐶𝑆𝐶𝐻4 mole C/g COD 

Biomass carbon content      𝐶𝑏𝑖𝑜 mole C/g COD 

 

Table 5 Kinetic Constant in MantisAD 

Parameter Symbol Unit 

Rate of disintegration 𝐾𝑑𝑖𝑠 1/d 

Hydrolysis rate of readily biodegradable particulate material 𝐾ℎ𝑦𝑑𝑟𝑏 1/d 

Hydrolysis rate of readily biodegradable soluble material 𝐾ℎ𝑦𝑑𝑠𝑏 1/d 

Readily biodegradable substrate uptake rate 𝜇𝑋𝑏𝑟 1/d 

Slowly biodegradable substrate uptake rate 𝜇𝑋𝑏𝑠 1/d 

Acetate degraders growth rate 𝜇𝑋𝐴𝑐 1/d 

Hydrogen degraders growth rate 𝜇𝑋𝐻2 1/d 

Biomass decay rate 𝑏ℎ 1/d 

Half saturation coefficient for readily biodegradable substrate uptake 𝐾𝑆𝑟𝑏 mg COD/L 

Half saturation coefficient for slowly biodegradable substrate uptake 𝐾𝑆𝑠𝑏 mg COD/L 

Half saturation coefficient for acetate uptake 𝐾𝑆𝐴𝑐 mg COD/L 

Half saturation coefficient for hydrogen uptake 𝐾𝑆𝐻2 mg COD/L 
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